Forums Read-only archive

Session failover fails on DNS error

4 posts · Brekeke SIP Server Forum

dstu Original post
1. Brekeke Product Name and Version:
SIP Server 3.6.3.0/454

2. Java version:
1.8.0_121

3. OS type and the version:
Linux 3.13.0-108-generic

4. UA (phone), gateway or other hardware/software involved:

5. Your problem:

When using the following rule, if the alias contains an address that can't be resolved (my colleague made a typo), it doesn't try the failover sessions that are defined in the "Deploy Patterns".


This is the dialplan rule:
------------------------
[Matching Patterns]
$request = ^INVITE
$addr = 10.0.0.10
To = sip:(123456)@
$alias.lookup("route_primary") = (.+)
$alias.lookup("route_failover1") = (.+)
$alias.lookup("route_failover2") = (.+)

[Deploy Patterns]
To = sip:%1@%2
$session = failover sip:%1@%3 sip:%1@%4
------------------------


In the aliases list, these were the entries:
  • route_primary = voip04.subnet4.lan (false, as subnet4.lan doesn't exist)
    route_failover1= voip02.subnet1.lan (server and subnet exist)
    route_failover2 = voip03.subnet1.lan (server and subnet exist)
This is the error in the error log:
DNS(1): Unknown Host: voip04.subnet4.lan
Is there anything we can set to make sure that the session failover will be implemented despite a DNS resolve error or is it a bug?

Thanks,

David
Haddas
David,
Failover doesn't cover unknown host DNS error because the error happens before the SIP Server sends an INVITE to the first destination.
Failover plugin starts monitoring timeout or SIP response after the first INVITE was sent.
dstu
Haddas wrote:
Failover doesn't cover unknown host DNS error because the error happens before the SIP Server sends an INVITE to the first destination.
Failover plugin starts monitoring timeout or SIP response after the first INVITE was sent.
Thank you for the explanation.

Is it possible to expand the failover mechanism to include also dns errors (and not wait for the failed/error response from the INVITE)?
Mike
Hi David,

I will discuss your request with the developer team.

Mike