Forums Read-only archive

The 3rd party database connection errors.

4 posts · Brekeke SIP Server Forum

Russell Original post
1. Brekeke Product Name and Version:
Brekeke SIP Server, Version 3.4.7.2

2. Java version:
1.7

3. OS type and the version:
AWS Linux

4. UA (phone), gateway or other hardware/software involved:

5. Your problem:
The 3rd party database cannot be connected.

The following are the settings:

1. I followed the document for setting 3rd party database:

http://www.brekeke.com/doc/sip/3rd_party_database.pdf

2. I downloaded the jdbc driver, from Oracle website
mysql-connector-java-5.1.36-bin.jar

I then copied the driver into "..../tomcat6/webapps/mysip/WEB-INF/lib

3. I setup and turned on the "Thirdparty Registered Database", "Thirdparty Users Database", "Thirdparty Alias Database"

However, the "User Authentication" has "Database error
" and I was unable to connect to the SIP server from my SIP App after I restarted it.

I believe the database is working, because I could access to the MySQL database remotely using the database tools like "Navicat" & I could access to the the database from the server shell as well.

The following are the error messages from the file "..../WEB-INF/work/logs/log.log":

ERROR (?:?) -
com.brekeke.net.sip.sv.registrar.RegisteredDBCanNotOpenException: JDBC Driver load error .com.mysql.jdbc.Driver; prop={user=dbuser
, password=xxxx, url=jdbc:mysql://www.xxxxxxx.com:3306/dbname, enabled=on, driver=com.mysql.jdbc.Driver, class=com.bre
keke.sipadmin.plugins.RegisteredSqlDB}
at com.brekeke.sipadmin.plugins.RegisteredSqlDB.newConnection(Unknown Source)
at com.brekeke.sipadmin.plugins.RegisteredSqlDB.initConnection(Unknown Source)
at com.brekeke.sipadmin.plugins.RegisteredSqlDB.open(Unknown Source)
at com.brekeke.sipadmin.plugins.RegisteredSqlDB.<init>(Unknown Source)
at com.brekeke.sipadmin.SipAdminBase.initDatabase(Unknown Source)
at com.brekeke.sipadmin.SipAdminBase.prepareServer(Unknown Source)
at com.brekeke.sipadmin.SipAdminBase.startServer(Unknown Source)
at com.brekeke.sipadmin.web.ServerInvoker.exec(Unknown Source)
at com.brekeke.web.Bean.execMain(Unknown Source)
at com.brekeke.sipadmin.SipAdminBase.execMain(Unknown Source)
at com.brekeke.web.Bean.execute(Unknown Source)
at com.brekeke.web.Bean.go(Unknown Source)
at com.brekeke.web.Bean.startBean(Unknown Source)
at com.brekeke.web.GateServlet.performTask(Unknown Source)
at com.brekeke.web.GateServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:643)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:723)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:861)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:620)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489)
at java.lang.Thread.run(Thread.java:745)


What could be wrong?
ambrosio
Check the following again.
- Database username. Is it "dbuser" ?
- Database password.
- Database URL and port.

Have you rebooted OS after you installed the JDBC driver?
If not, let you reboot the OS.

Can you use MySQL as Registered Database and Alias Database without any issues?
Russell
Hi,

Thanks for the reply. It works after I reboot the OS.
ambrosio
Glad to know it!

Without rebooting OS or kill Java processes, JDBC's JAR will not be added into the CLASSPATH.