Forums Read-only archive

Reject Calls

13 posts · Brekeke SIP Server Forum

lperezu Original post
1. Brekeke Product Name and Version: Version 3.2.4.3 Evaluation

2. Java version: 1.7.0_25

3. OS type and the version: Linux RH 6 2.6.32-131.0.15.el6.x86_64

4. UA (phone), gateway or other hardware/software involved:

5. Your problem:

Can Brekeke Sip Server Reject all calls that did not match any rule in the Dial Plan?
hope
create the rule and put below all other rules

Matching patterns
$request = ^INVITE

Deploy Patterns
$response = 603

If the call cannot apply any rule above this one, sip server will reply 603 for the invite
lperezu
I Did It, but Brekeke Reject All the calls. I Put this rule in the last row.

In the History (Dial PLan) I see that the call apply the 2 rules but the gateway (brekeke) reply 603 to all calls although match the first rule (send the call to a PBX)

can you helpme?
james
Can you find associated calls in the [Calls Logs] or [Error Logs] page?
lperezu
I can see the Call in Error Log ( $response=603). The call match the 2 rules (TO_PBX_SIP & REJECTEDS) but I need the call that match the first rule (rule TO_PBX_SIP) be send to the PBX and not rejected too (rule REJECTEDS).

Can you help me?
james
> The call match the 2 rules (TO_PBX_SIP & REJECTEDS)

It means your first rule "TO_PBX_SIP" doesn't point any destination.

Add "To=" or "$target=" in the Deploy Pattern in the rule "TO_PBX_SIP" to point PBX's IP address:port.

If so, it works.
lperezu
This is my Matching Patterns and Deploy Pattern of the rule TO_PBX_SIP:

Matching Patterns

$request = ^INVITE
$registered = false
To = 202020@
To = sip:(.+)@
$route.underlimit( "%1","10" ) = true

Deploy Pattern

$routename = %1
$continue = true
$auth = false
$transport = udp
To = sip:101010@PBX_IP_ADDRESS

But the problem persist.

Can you helpme?
james
> To = sip:101010@PBX_IP_ADDRESS

Did you specify PBX's port number there?

For example:
To = sip:101010@PBX_IP_ADDRESS:15060
lperezu
James thanks for youre help,

I put now the number of port in the rule but the call is rejected again. (takes the second rule and is rejected)

can you helpme?
james
The 603's rejection happens even if you disable the rule "REJECTEDS"?
lperezu
James,

when I disable the rule REJECTEDS, the call is sent correctly to the PBX.

But I need, Brekeke Sip Server Reject all calls that did not match any rule in the Dial Plan.

I need REJECTEDS rule for Filtrer possible no permitted Calls.
hope
try removing $continue = true from rule "TO_PBX_SIP" if no other rule below needs to apply to the call
and put reject rule at the bottom of all other rules
lperezu
Thanks hope,

the solution is replace the line $continue = true by $continue = false