Forums Read-only archive

SIP server can't register

8 posts · Brekeke SIP Server Forum

Handerson Original post
1. Brekeke Product Name and version:
SIP Server v3.x

2. Java version:
6.0.310

3. OS type and the version:
Win7 Home Ed

4. UA (phone), gateway or other hardware/software involved:
X-Lite, QuteCom softphones, and Grandstream IP phone

5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :
Pattern 1

6. Your problem:
I downloaded the latest SIP server V3.x, and installed on computer A (Windows 7 OS). X-Lite softphone installed in Computer A as well, QuteCom softphone installed in Computer B (WinXP OS), and an IP phone in the same LAN.

I can start SIP server in Computer A with the trial account, and created two user accounts following the Quick Start Guide. User IDs are 100 and 101. 100 is assigned to X-Lite phone, 101 assigned to QuteCom phone. If I use all default settings in SIP server, then X-Lite phone can't register at all; if I make SIP Authentication Register and Invite off, the X-Lite can register, but QuteCom can't. The IP phone was used to replace QuteCom and assigned 101; it could not register either.

It is a simple test in the first trial but failed :cry: Anybody can help me out please? Thanks~~
janP
it is weird...
Did you restart the SIP Server after you tuned the Authentication settings?
Handerson
janP wrote:it is weird...
Did you restart the SIP Server after you tuned the Authentication settings?
Yes, I restarted the server. I even tried to restart the computer.
Anybody can share your successful experience in installing SIP server V3.x in Windows?
Tata
are you sure the REGISTER authentication is off?
Handerson
Tata wrote:are you sure the REGISTER authentication is off?
If I set Configuration -> SIP -> Authentication -> REGISTER on, then X-Lite can't register, and the message X-Lite said is:
Account failed to enable
Account A could not be enabled.
Unknown error. Contact your administrator.

This X-Lite is installed in the same computer as the SIP server.

I have also installed another X-Lite in another computer in the same LAN. It showed error message a bit differently:
Account failed to enable.
Account B could not be enabled.
Problem at server (SIP error 408). Try again later.

Is this error message useful for you?

=======================
If I set Configuration -> SIP -> Authentication -> REGISTER off, and restart SIP server, then the X-Lite in the same computer can register, but the X-Lite in another computer could not.
Tata
It seems funny.

Are there any firewall or router which enables SIP-ALG?
A SIP-ALG will modify/block SIP packet sent from X-Lite.

For avoiding such an issue, I recommend that you test SIP at a clean environment at first.
Handerson
Tata wrote:It seems funny.

Are there any firewall or router which enables SIP-ALG?
A SIP-ALG will modify/block SIP packet sent from X-Lite.

For avoiding such an issue, I recommend that you test SIP at a clean environment at first.
Thanks guys. I finally solved the problem by disabling Windows firewall. Your guys' discussion helped in heading in the right direction. :D
Tata
Wow...

If you open the following ports at the firewall, you don't have to disable it.
-----------------------------------
UDP:5060 (for SIP packet)
UDP:10000-10999 (for RTP packet)
-----------------------------------

http://wiki.brekeke.com/wiki/Using-Brek ... a-firewall