Forums Read-only archive

Error installing PBX on Centos 5.5

2 posts · Brekeke PBX Forum

juanmanuel Original post
1. Brekeke Product Name and version:PBX Version 2.4.7.3

2. Java version:

3. OS type and the version:

4. UA (phone), gateway or other hardware/software involved:

5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :

6. Your problem:

I m traying to install Brekeke PBX version 2.4.7.3 on Centos 5.5, when I try to reach the admin web http://IP_address:8080/pbx returns the follwing message:

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.NullPointerException
java.io.File.<init>(File.java:239)
com.brekeke.pbx.common.UserManager.getUserDataFilename(Unknown Source)
com.brekeke.pbx.common.UserManager.initLicense(Unknown Source)
com.brekeke.pbx.common.UserManager.hasLicense(Unknown Source)
com.brekeke.pbxadmin.web.PbxLogin.exec(Unknown Source)
com.brekeke.web.Bean.execMain(Unknown Source)
com.brekeke.pbxadmin.PbxAdminBase.execMain(Unknown Source)
com.brekeke.web.Bean.execute(Unknown Source)
com.brekeke.web.Bean.go(Unknown Source)
com.brekeke.web.Bean.startBean(Unknown Source)
com.brekeke.web.GateServlet.performTask(Unknown Source)
com.brekeke.web.GateServlet.doGet(Unknown Source)
javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)


Any body knows way this error message is returned?

Thanks and best regards
Haddas
I suppose you are using the pre-installed Tomcat..
Let you use the latest version Tomcat.