Forums Read-only archive

how to configure register server differ from proxy address?

20 posts · Brekeke SIP Server Forum

lvbin Original post
1. Brekeke Product Name and version:2.4.7.3 evalution version

2. Java version:

3. OS type and the version:windows 2003

4. UA (phone), gateway or other hardware/software involved:

5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :

6. Your problem:
how to configure the register domain different with proxy address? I remembered it worked before but when upgraded to 2.4.7.3, it changed. Who can help me to solve it?

Thanks a lot!
james
do you mean "multiple domains" for register?
see the section "3.8.6. Domains" in the document.
http://www.brekeke-sip.com/download/bss ... min_en.pdf
lvbin
james wrote:do you mean "multiple domains" for register?
see the section "3.8.6. Domains" in the document.
http://www.brekeke-sip.com/download/bss ... min_en.pdf
I mean how to configure brekeke to accept the domain name in sip message is not proxy ip address. it's another domain name. for example, brekeke server ip is 172.18.104.111. but the domain name in register message is brekeke.com.
hope
is "thru registration" at sip server/configuration/sip set to On?
lvbin
hope wrote:is "thru registration" at sip server/configuration/sip set to On?
whether on or off, the register is still failed. if the From header like
From: <sip:861064361185@brekeke.com>; tag=ac113435
the register will be rejected even cancel the Authentication requirement.

which parameter decide it? Thanks a lot!
hope
if the domain doest not exist, brekeke sip server will have the register record in registered clients
if domain exists but no sip server at that domain, you need following dial plan
matching
$request=^REGISTER
deploy
$target=localhost
$continue=true
lvbin
hope wrote:if the domain doest not exist, brekeke sip server will have the register record in registered clients
if domain exists but no sip server at that domain, you need following dial plan
matching
$request=^REGISTER
deploy
$target=localhost
$continue=true
It's works. Thanks a lot!
lvbin
lvbin wrote:
hope wrote:if the domain doest not exist, brekeke sip server will have the register record in registered clients
if domain exists but no sip server at that domain, you need following dial plan
matching
$request=^REGISTER
deploy
$target=localhost
$continue=true
It's works. Thanks a lot!
Hi,

Another issue when we tried again today, server reply "483 too many hops" error. We didn't changed server configuration and the max-forwards value of reques is 70. Do you know the reason? Thanks a lot!
james
do you get the "483 too many hops" error with REGISTER?
lvbin
james wrote:do you get the "483 too many hops" error with REGISTER?
Yes. nothing to change. both server and client.
james
How about this??
-----------------------------
[Matching Patterns]
$request = ^REGISTER

[Deploy Patterns]
$target = localhost
$action = register
-----------------------------
lvbin
james wrote:How about this??
-----------------------------
[Matching Patterns]
$request = ^REGISTER

[Deploy Patterns]
$target = localhost
$action = register
-----------------------------
Hi,

register is passed. but basic call failed:-(.
hope
matching
$request=^INVITE
To = sip:(.+)@

deploy
To = sip:%1@
lvbin
hope wrote:matching
$request=^INVITE
To = sip:(.+)@

deploy
To = sip:%1@
Hello,

My dial plan as below. As this configuration, the register failed. Could you please help to check? Thanks

matching
$request=^REGISTER
$request=^INVITE
To = sip:(.+)@

deploy
$target=localhost
$continue=true
$action = register
To = sip:%1@
hope
make two dial plan, one for register one for invite
use one $request in one dial plan
and better to use wireshark to capture packets about failed call
and check if there is any response code from brekeke
lvbin
hope wrote:make two dial plan, one for register one for invite
use one $request in one dial plan
and better to use wireshark to capture packets about failed call
and check if there is any response code from brekeke
it works. Thanks a lot!
lvbin
hope wrote:make two dial plan, one for register one for invite
use one $request in one dial plan
and better to use wireshark to capture packets about failed call
and check if there is any response code from brekeke
Hello,

Do we support create sub in batch mode? Thanks
janP
what does "create sub in batch mode" mean??
lvbin
janP wrote:what does "create sub in batch mode" mean??
I mean how to create more subscirbers? currently I have to do it one by one via GUI? can we support batch mode? such as edit a script and import it.
janP
Does your "subscribers" mean "Authentication User" ?

You can import users at the [User Authentication] > [Import Users] page.

Refer the document for more details.