Forums Read-only archive

TIMEOUT ON SERVER REQUEST

11 posts · Brekeke SIP Server Forum

max_d29 Original post
1. Brekeke Product Name and version: 2.4.73

2. Java version: 6/22

3. OS type and the version: windowx xp sp3

4. UA (phone), gateway or other hardware/software involved: Tenor Quitnum Gateway

5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :


6. Your problem: I've seting a dialplan, where when make a call routing in other ip:

match
$request=INVITE
To=sip:0(62812.+)@

deploy
To=sip:%1@10.107.21.54

So, if the 10.107.21.54 not are avalable the time expired, is set at 60 seconds. I want to setup this parameter timeout at 3 second..... but not found the correct parameter for make this work.

How can do?

Thx at all
hope
set invite timeout in deploay pattern?
&net.sip.timeout.inviting=3000
max_d29
I've try it to make this, but continue to have a timeout of 60 second first to have the error 408 in return....

(when i make the new configuration havew make the restart of entire sip server too)

How can do for resolve the problem?
max_d29
BIG ERROR.....
i'm very sorry....+but the error is 504 NOT 408.
then i must to change the timeout of contact server.
Now have 60 seconds first to have error 504.
how can reduce to 3 secondS?

thank's
hope
is the call applied the dial plan with invite timeout?
did you click apply rule button after adding the line in deploy pattern?
does 10.107.21.54 exist and reachable from brekeke server?
max_d29
yes, but i not sent the invite, because, the remote server is down, than the problem is first...........
the brekeke try to contact the remote server for sent the invite, but this not are more present in lan.
then the brekeke wait 60 seconds first to responde at the remote request client the error 504............
so, for control this timeout not can use the &net.sip.timeout.inviting=3000
what kind of command i must to use int the dialplan?
thanks

ps. second question: yes push apply first to retry
third question: no not exist (server shutdow or damage) than not reachable
hope
capture packets and check
- is caller using tcp for the call?
if yes, then the timeout depends on OS setting, can not change it from brekeke
- does caller keep sending invite packets?
if yes, the timeout will not happen
- check if the To header can match the To in your dial plan "Matching patterns" it is To: sip:062812...@
if not match, the dial plan is not applied to the call.
james
max..

are you using the Failover plugin??

does the issue still happen even if you put "net.sip.timeout.inviting=3000" in the [Configuration] > [Advanced] page ?
max_d29
can't use the failover plugin because have the standard edition and not advanced.
but make the second action in the configuration-advanced how you suggest.... Thx
max_d29
The "net.sip.timeout.inviting=3000" in the [Configuration] > [Advanced] go so well.... now i've resolve all.
thanks'
james
Wow..
it seems the cause of your dialplan problem is .. the rule is not used..
maybe syntax error.