Forums Read-only archive

How to monitor end points with XYMON via Brekeke

21 posts · Brekeke SIP Server Forum

noiptel Original post
1. Brekeke Product Name and version:

2. Java version:

3. OS type and the version:

4. UA (phone), gateway or other hardware/software involved:

5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :

6. Your problem:

We have various remote Quintum Tenor endpoints with dynamic IP internet service.

All Quintums register every 300 seconds to our Brekeke SIP Server.

How can we use the IP address information reflected on the SIP Server to monitor our Quintum network via XYMON or any other network monitoring application?

Thanks
taitan
You can monitor updated client's remote IP addresses at the Registered Clients page.

Does it meet your requirement?
noiptel
In the past we used Xymon to monitor our remote Quintum network via DNS as all of our remote Quintums have Dynamic IP internet service. Now that we have incorporated the Brekeke SIP server into our network we can no longer use DNS.

Do you know of a network monitoring application (perhaps similar to Xymon) that will work by using the IP's posted on the Registered Clients page?

Xymon is a system for monitoring of hosts and networks, inspired by the Big Brother system. It provides real-time monitoring, an easy web-interface, historical data, availability reports and performance graphs. Xymon was previously known as "Hobbit".
http://sourceforge.net/projects/hobbitmon/

Thanking you in advance.
taitan
Ok. I understood.

Which edition of SIP Server are you using?
If you are using Advanced Edition, you can use Failure Notification feature for monitoring a SIP UA.
http://wiki.brekeke.com/wiki/Brekeke-SI ... tification

In your case, if Tenor is down then the notification mail will be sent to you.
noiptel
We currently have the Standard Edition.

The Failure Notification feature will be great to have. However, we would like to have Failure Notification historical data, availability to reports and performance graphs.

How can we go about doing this?
taitan
The Failure Notification feature can monitor any SIP device even if the device's IP address is a dynamic because it can use a device's REGISTER IP address.

With the Failure Notification, the SIP Server sends a notification mail to you if the SIP device is down. It means you can keep these mails as historical data.

You can ask Brekeke's sales team to provide an evaluation license of Advanced Edition.
noiptel
We upgraded to the Advance Edition.

I have added some remote Tenor Endpoints to the Heartbeat page.

However, only if I put in the current IP address of the tenor the feature works well. The problem is that all the IP addresses for the for remote tenors are dynamic. I suppose once the IP address changes we will get a false failure e-mail notification.

What should I put in the SIP URI field so that the heartbeat feature work for us?
taitan
OK..

>> What should I put in the SIP URI field so that the heartbeat feature work for us?

Are Tenor Endpoints registered in the SIP Server? right?
If so, set "sip:username@localhost" in [SIP URI]. (username should be Tenor's registered name...)
and set "404" in [Response Codes].
noiptel
The below Endpoint Tenor is registered in the "Registered Clients" as follows:

User
im5q1

Contact URI
sip:im5q1@192.168.1.60:5106

Detail
Expires : 300
Priority : 1000
User Agent : Quintum/1.0.0 SN/0030E1030BD4 SW/P107-09-00
Requester : 189.147.171.101:5106
Time Update : Mon Jun 21 17:23:58 CDT 2010


Heartbeat settings:

Heartbeat 1
Heartbeat Monitoring Method: SIP
SIP URI: sip:im5q1@192.168.1.60:5106
Interval: 30
Response Codes: 404

Please confirm what I am doing wrong as I am still getting a Failure.
hope
i think Taitan said to set sip:username@localhost in [SIP URI]. it is "sip:im5q1@localhost"
taitan
Yes.. right.
noiptel
Thanks for your response, but unfortunately is still not working I have tried the following settings for SIP URI and they all go immediately to "Failed", the only way it works is configuring heartbeat as NETWORK and putting the public IP of the UA, but this is not desirable because the IP changes

sip:im5q1@localhost
sip:im5q1@<IP of the server>
sip:im5q1
sip:im5q1@
im5q1
sip:im5q1@192.168.1.60:5106
sip:im5q1@192.168.1.60
sip:im5q1@<public IP of the UA>
im5q1@<public IP of the UA>

What could be wrong ?
noiptel
We will appreciate your asssitance with this matter.

Thanks.
taitan
Hi

If UA is registered as the username "im5q1", set "sip:im5q1@localhost" at [SIP URI] field.

Are you sure "im5q1" is registered in the SIP Server?
noiptel
I have copy and paste the information reflected on the "Registered Clients" screen.

User
im5q1

Contact URI
sip:im5q1@192.168.1.60:5106

Detail
Expires : 300
Priority : 1000
User Agent : Quintum/1.0.0 SN/0030E1030BD4 SW/P107-09-00
Requester : 189.147.148.91:5106
Time Update : Wed Jun 30 06:59:18 CDT 2010
noiptel
Please find below the call log generated when running Heartbeat 1.

java.net.SocketTimeoutException: Receive timed out
at java.net.PlainDatagramSocketImpl.receive0(Native Method)
at java.net.PlainDatagramSocketImpl.receive(PlainDatagramSocketImpl.java:136)
at java.net.DatagramSocket.receive(DatagramSocket.java:712)
at com.brekeke.net.sip.common.SIPpacketInvoke.invoke(Unknown Source)
at com.brekeke.siptool.haman.HeartbeatSIP.sendPacket(Unknown Source)
at com.brekeke.siptool.haman.HeartbeatSIP.run(Unknown Source)
at java.lang.Thread.run(Thread.java:619)
null(2) is down!!

Email sent to:noc@noiptel.com
taitan
Do you get the "Failed" even if the "im5q1" is registered?
Can you make a call to "im5q1" from another SIP account?
noiptel
Yes, the UA is registered and has normal calls on it. The failed event shows as soon as we start the heartbeat, That is why I suspect heartbeat is not working rigth. Is there a pre-requisite for it ? We are currently running Java DB 10.4.2.1.
taitan
Ok..
Remove "404" from [Response Codes] and keep it blank.
noiptel
404 removed. We still get the immediate "Failed" status.
taitan
Do you have any other device instead of Quintum Tenor?

Try your Heartbeat settings with another device..
I want to know if the issue happens only with the Quintum..


Also, can you capture packet at server PC with wireshark??