Forums Read-only archive

URI / Requester Ports

21 posts · Brekeke SIP Server Forum

damatta Original post
1. Brekeke Product Name and version: Brekeke SIP Server , Version 2.1.6.6 Standard

2. Java version: 1.5.0_14

3. OS type and the version: Windows 2003 Entreprise

4. UA (phone), gateway or other hardware/software involved: Grandstream HT-486

5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html : 9

6. Your problem: Noticed that sometimes UA registers with different ports for SIP-URI and REQUESTER. That makes me losing incoming traffic from PSTN (DID). Any help will be deeply appreciated. :)
lakeview
Are UA clients behind NAT?
Disable STUN at UA settings.
damatta
Yes, behind NAT. But, no STUN configured.
lakeview
go to server's GUI -> [Configuration] -> [SIP] -> [NAT traversal].
And select [Add 'rport' parameter (Receive)] = "true".

Try it.
damatta
It did not work out... :(
lakeview
Try the latest beta version..
http://www.brekeke.com/download/download_sip_beta.php

It has improved NAT detection feature.
damatta
No success after upgrade. Worst: now ALL DID's can't receive calls. BSS sends error 486 (busy here) for ALL incoming calls. Please help.
lakeview
Are you using Brekeke PBX ?
damatta
Yes, I am.
lakeview
Do you have a user in the PBX?
If not, you need to create certain users in the PBX.
damatta
We have both: PBX and BSS users.
lakeview
Hi damatta,

Can you paste 486 error response packet here?
Or, can you see"User-Agent" header in the response packet?
damatta
Incoming traffic issue solved (NAT problem, not).Thanks.
Harold
Try this DialPlan rule.
=========================================
[Matching Patterns]
$request = ^REGISTER
$globaladdr( Contact ) = true
$addr = (.+)
$globaladdr( "%1" ) = true
$port = (.+)

[Deploy Patterns]
&register.contact.addrport = %1:%2
&register.contact.nat = true
$continue = true
=========================================
damatta
After applying this Dial Plan, some lines became RED. So, I assume there are synthax errors.

Matching Patterns:

$globaladdr(Contact)=true
$globaladdr("%1")=true

Deploy Patterns:

&register.contact.addrport=%1:%2
&register.contact.nat=true
lakeview
Hi all,

Harold's DialPlan seems no problem.

>> After applying this Dial Plan, some lines became RED. So, I assume there are synthax errors.

Don't worry. you can use these variables.
These variables are new from version 2.2 beta.. so they are not listed in the DialPlan's spell checker.
damatta
Fine now :)
lakeview
Wow..

Does Harold's DialPlan solve the issue??
damatta
Well, partially... Signalling issue was solved (can receive calls) but not media (no audio).
lakeview
Did you set "RTP-Relay=on"??
If not, try it.
damatta
Yes, RTP Relay setting is ON and RTP relay (UA on this machine) is AUTO.