1. Brekeke Product Name and version:
SIP Server 2.0.7.2
PBX 2.1.1.3
2. Java version:
Apache Tomcat/5.5.20
Java 4.1.2 20070626 (red Hat 4.1.2-13)
3. OS type and the version:
Fedora Core 6 version 2.6.22.1-32.fc6 #1 i686 i386
on HP Proliant ML110
4. UA (phone), gateway or other hardware/software involved:
None
5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :
Pattern 4
6. Your problem:
For PBX Server
After entering registration code the following occurs:
HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException: Servlet execution threw an exception
root cause
java.lang.UnsatisfiedLinkError: getUD0
com.brekeke.tel.sip.stack.jni.InviteHandler.getUD(Unknown Source)
com.brekeke.pbxadmin.PbxAdminBase.newUserDataFile(Unknown Source)
com.brekeke.pbxadmin.web.PbxInputId.exec(Unknown Source)
com.brekeke.web.Bean.execMain(Unknown Source)
com.brekeke.pbxadmin.PbxAdminBase.execMain(Unknown Source)
com.brekeke.web.Bean.execute(Unknown Source)
com.brekeke.web.Bean.go(Unknown Source)
com.brekeke.web.Bean.startBean(Unknown Source)
com.brekeke.web.GateServlet.performTask(Unknown Source)
com.brekeke.web.GateServlet.doPost(Unknown Source)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
note The full stack trace of the root cause is available in the Apache Tomcat/5.5.20 logs.
Apache Tomcat/5.5.20
=========================================
For the SIP Server
HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
java.lang.IllegalStateException: enc
com.brekeke.util.EasyCryptoUtil.enc(Unknown Source)
com.brekeke.sipadmin.web.LogSelect.getUD(Unknown Source)
com.brekeke.sipadmin.SocketWrap.getUD(Unknown Source)
com.brekeke.sipadmin.SipAdminBase.newUserDataFile(Unknown Source)
com.brekeke.sipadmin.web.InputLicense.exec(Unknown Source)
com.brekeke.web.Bean.execMain(Unknown Source)
com.brekeke.web.Bean.execute(Unknown Source)
com.brekeke.web.Bean.go(Unknown Source)
com.brekeke.web.Bean.startBean(Unknown Source)
com.brekeke.web.GateServlet.performTask(Unknown Source)
com.brekeke.web.GateServlet.doPost(Unknown Source)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
note The full stack trace of the root cause is available in the Apache Tomcat/5.5.20 logs.
Apache Tomcat/5.5.20
======================================
Also made sure that the C Libraries are installed
have a similar problem with PBX on OSX, SIP server works perfectly on OSX
Puzzled, can you help
Many Thanks
Bernie O'Neill
SIP Server 2.0.7.2
PBX 2.1.1.3
2. Java version:
Apache Tomcat/5.5.20
Java 4.1.2 20070626 (red Hat 4.1.2-13)
3. OS type and the version:
Fedora Core 6 version 2.6.22.1-32.fc6 #1 i686 i386
on HP Proliant ML110
4. UA (phone), gateway or other hardware/software involved:
None
5. Select your network pattern from http://www.brekeke-sip.com/bbs/network/ ... terns.html :
Pattern 4
6. Your problem:
For PBX Server
After entering registration code the following occurs:
HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
javax.servlet.ServletException: Servlet execution threw an exception
root cause
java.lang.UnsatisfiedLinkError: getUD0
com.brekeke.tel.sip.stack.jni.InviteHandler.getUD(Unknown Source)
com.brekeke.pbxadmin.PbxAdminBase.newUserDataFile(Unknown Source)
com.brekeke.pbxadmin.web.PbxInputId.exec(Unknown Source)
com.brekeke.web.Bean.execMain(Unknown Source)
com.brekeke.pbxadmin.PbxAdminBase.execMain(Unknown Source)
com.brekeke.web.Bean.execute(Unknown Source)
com.brekeke.web.Bean.go(Unknown Source)
com.brekeke.web.Bean.startBean(Unknown Source)
com.brekeke.web.GateServlet.performTask(Unknown Source)
com.brekeke.web.GateServlet.doPost(Unknown Source)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
note The full stack trace of the root cause is available in the Apache Tomcat/5.5.20 logs.
Apache Tomcat/5.5.20
=========================================
For the SIP Server
HTTP Status 500 -
type Exception report
message
description The server encountered an internal error () that prevented it from fulfilling this request.
exception
java.lang.IllegalStateException: enc
com.brekeke.util.EasyCryptoUtil.enc(Unknown Source)
com.brekeke.sipadmin.web.LogSelect.getUD(Unknown Source)
com.brekeke.sipadmin.SocketWrap.getUD(Unknown Source)
com.brekeke.sipadmin.SipAdminBase.newUserDataFile(Unknown Source)
com.brekeke.sipadmin.web.InputLicense.exec(Unknown Source)
com.brekeke.web.Bean.execMain(Unknown Source)
com.brekeke.web.Bean.execute(Unknown Source)
com.brekeke.web.Bean.go(Unknown Source)
com.brekeke.web.Bean.startBean(Unknown Source)
com.brekeke.web.GateServlet.performTask(Unknown Source)
com.brekeke.web.GateServlet.doPost(Unknown Source)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
javax.servlet.http.HttpServlet.service(tomcat5-servlet-2.4-api-5.5.23.jar.so)
note The full stack trace of the root cause is available in the Apache Tomcat/5.5.20 logs.
Apache Tomcat/5.5.20
======================================
Also made sure that the C Libraries are installed
have a similar problem with PBX on OSX, SIP server works perfectly on OSX
Puzzled, can you help
Many Thanks
Bernie O'Neill